Weird missing assembly error

Jan 11, 2011 at 7:22 PM

The exact compile error is: "The type or namespace name 'Cjc' could not be found (are you missing a using directive or an assembly reference?)"


I've added the project references and Cjc.ChromiumBrowser and Cjc.Awesomium assembles were both added in the references folder but whenever I try to use the namespace or reference it in xaml it gives me this error.  The demo program works fine and I have a copy of Awesomium in the project folder.


In fact, I've compiled the demo program then confirming that it works I've added a new project to the solution while changing the startup program from the Demoprogram to the new project and added the necessary references but still no luck.

 

What am I missing here?  Why can the DemoProgram recognize the Cjc assemblies but anything I make can't?

Mar 30, 2011 at 4:12 PM

I'm having the same problem and I'm going round in circles trying to fix it.  I now have the demo program and my program in the same project - the demo program works fine when set as the Startup project, mine works fine when set as the startup project.  I have set the references in my project to match the demo project exactly.  After I have set the references, I add "using Cjc.ChromiumBrowser" - Visual Studio even predicts "Cjc" and "ChromiumBrowser".

YET as soon as I hit compile, it changes its mind and gives me this error.  It marks "Cjc" with the red underlining and refuses to predict "Cjc" any more.  It's as if it loses the reference completely even though nothing has changed.  

 

I have spent days trying to figure this out.  I need some way of rendering HTML in a WPF control, and I can't find any other options out there other than to use Awesomium.  

 

vanp - please tell me you got somewhere with this?  I get the feeling these discussion boards have been abandoned.  

Mar 30, 2011 at 4:22 PM

I was able to get around it but it's really dumb and hackish.

 

Instead of adding the Cjc.ChromiumBrowser to my solution I've started adding my project to the Demoprogram and it works!

 

Warning: Don't rename the demo program because then it won't work again.....

Jul 22, 2011 at 10:45 AM

Changing the project framework to DotNet 4 (not the client profile) solved this for me.